Username
Password
  
Fable 3

Fable 3 Achievements

Island Paradise

10
Establish the island of Driftwood.  

Quest: Driftwood chain - Restoration, Pest Control & Giftwood for Driftwood
Worth: Guild Seals
Location: Driftwood
How to Complete: There are a couple of quests you must complete before you can get this. Here's a breakdown of each quest:

Quest: Restoration
Worth: 5 Guild Seals
Location: Millfields
How to Complete: Follow your gold trail until you reach Griffith Smith on top of a hill (recognize this area?). All he asks for is 750 gold to help build the bridge. Pay him and the quest is complete.

Return here later to cross the bridge to the old gypsy camp and to go north into Driftwood.

Quest: Pest Control
Worth: 5 Guild Seals
Location: Driftwood
How to Complete: Speak to Robin on the beach. He explains that Driftwood wants to expand but they can’t because of the Hobbes. Swim to the larger island offshore and start your Hobbe hunting! They're spread out across the 3 large islands but your gold trail will show you which way to go next after each batch. Kill them all and return to Robin to complete the quest.

Quest: An Island Getaway
Worth: 5 Guild Seals
Location: Bowerstone Market
How to Complete: Meet Rusty on the 2nd floor of the Bowerstone Market and agree to take him to the new Driftwood. Then simply, escort him across Albion to Driftwood and let him go onto the new islands.

Quest: Giftwood for Driftwood
Worth: 10 Guild Seals
Location: Driftwood
How to Complete: Cross a new bridge onto the other island and talk to the villager. Again Driftwood wants to expand but it seems they don’t have a good enough carpenter. He'll hand you a letter to take to one of the best carpenters in Albion, who lives in Silverpines.

Either run all the way there or use fast travel but once you've handed him the letter the quest is complete. You must now leave Driftwood for the effects to take place and about 15 minutes later the achievement will pop.

Rate this achievementAverage Rating (Based on 8 votes)
 
 
User Comments
Comment #1 by Taylormansa
Sunday, October 31, 2010 @ 12:51:25 PM

I completed Pest Control and then Get Wood For Driftwood in that order and it
didn't pop. So i did Island Get Away to try to get it and it still didn't pop.
Did I do everything or is something out of order??

Comment #2 by shipkey1586
Monday, November 01, 2010 @ 06:13:53 PM

I don't know, I've done the Pest Control and Get Wood for Driftwood, and also the escort the gambler guy there and I still haven't gotten it either.

Comment #3 by lazai
Tuesday, November 02, 2010 @ 09:48:20 AM

completed this quest and achvie didnt pop wasnt till like 3 hours later did it pop for me so maybe it takes awhile who knows

Comment #4 by PyrathasResrctd
Wednesday, November 03, 2010 @ 04:48:23 PM

I dont even see Pest control or Get Wood for Driftwood in my quest list and I have just barely anymore time before the final battle

Comment #5 by BigRed8485
Thursday, November 04, 2010 @ 09:27:12 PM

I did the Pet Control and Get Wood for Driftwood quests and it didnt pop, then
I have a kid and it popped. Wierd.

Comment #6 by QueenMirage
Friday, November 05, 2010 @ 04:41:04 AM

I did the Pest Control, Get wood for Driftwood, and another quest to take Rusty in Bowerstone Market to Driftwood Island, my achievement unlocked a few minutes after that/

Comment #7 by Mitchellflavor
Sunday, November 07, 2010 @ 11:20:44 AM

how do you get those quests?

Comment #8 by TheRedComet88
Sunday, November 07, 2010 @ 01:06:53 PM

I have the strategy Guide and apparently after you do the Get Wood for Driftwood quest you need to walk out of the village and it should pop. However after following these steps it did not pop for me, and I am still waiting for it. Also before you do Pest Control quest you need to do the Restoration Quest. Which is giving 7000 gold to some guy wanting to restore the island.

Comment #9 by jaysquared2
Monday, November 08, 2010 @ 06:36:33 PM

Glad to see I'm not the only one who hasn't got this cheevo to pop. I've almost done every single quest in the game and I still have yet to get this to pop. I have done everything needed for this to unlock with no luck. Seems this is a glitchy achievement. Hopefully they fix this soon.

Comment #10 by Cambra
Monday, November 08, 2010 @ 11:28:57 PM

After you get wood for driftwood (by convincing the lumber guy in silverpine to
move there) you have to convince another person too in industrial, you gotta
hold hands the entire way there it kinda sucks but after he gets there your wait
like one hour real life time and the acheivement pops up

Comment #11 by DaDeeJaay
Tuesday, November 09, 2010 @ 01:17:58 PM

wich way from mistpeak leads to driftwood really I dont now lol

Comment #12 by Cambra
Tuesday, November 09, 2010 @ 05:52:45 PM

sorry i meant market not industrial

Comment #13 by Cuthred
Sunday, November 14, 2010 @ 09:29:11 AM

did all the quests as well and the achievement did not pop ... until I slept for some time (e.g. until morning) ... then it poped.

Comment #14 by Garg
Sunday, November 14, 2010 @ 03:26:02 PM

I can confirm that sleeping until the morning appears to work quite nicely. Popped immediately when I slept.

Comment #15 by daniel book
Thursday, November 18, 2010 @ 08:40:01 AM

Popped unexpectedly.

Comment #16 by WWG II assassin
Monday, November 29, 2010 @ 05:39:54 PM

Ive draged the guy there, I've slept and still nothing WWWWWWHHHHHHHHYYYYYYYY!?!?!?

Comment #17 by CyborgPanda078
Friday, December 03, 2010 @ 08:33:30 PM

It popped immediateley for me after the silverpines guy quest so it probly glitches but it should pop. And i dont know if this was answered but #4, the quests dont appear themselves, you have to go to millfields i think and then find a bridge where you just pay the guy to explore

Comment #18 by Andrew 98
Saturday, December 11, 2010 @ 03:55:04 PM

pest control came up but i cant find it.someone tell me if u hav to wait.

Comment #19 by NickOwnage
Friday, December 24, 2010 @ 07:17:11 AM

How do in get on the island? Ive got a Quest Marker above the island.
But not in the Quest List.

Comment #20 by NickOwnage
Friday, December 24, 2010 @ 08:08:10 AM

By the Way, ive got it. I did Pest Control.

Comment #21 by dauntedmetal
Wednesday, December 29, 2010 @ 07:33:45 PM

i did all the quests but then i traveled to a different area and then got it

Comment #22 by Melanopterus
Friday, December 31, 2010 @ 06:28:52 PM

I am so confused the quest to take the letter to the guy will not open up for me. I've escorted the guy, and cleared the hobbes but it will just not give the third quest. I am afraid if I progress to far in the game it might not ever become open. Did anyone else have this problem? Any ideas or suggestions?

Comment #23 by IREaP4Rz
Wednesday, January 05, 2011 @ 02:45:02 PM

ive dont the quest before pest controll 3 hours ago and i havent got the pest controll achievment

Comment #24 by xI Kalika Ix
Wednesday, January 05, 2011 @ 06:15:53 PM

I can't even find the Giftwood For Driftwood Quest... Help??

Comment #25 by sweetangel1984
Thursday, January 06, 2011 @ 09:51:17 AM

I was stuck, quests didn t pop. did quest the debt in bowerstone market (I think), and got an new quest in driftwood. yeah.

Comment #26 by dragaria
Monday, January 10, 2011 @ 07:45:21 AM

i have done everything, like killing all the hobbs, giftwood (getting the tree and lumberjack(or what he is)) and helpet that gambler to get there and i still not got it and i have w8et like 4 hour now, do i have do something more :O plz help

Comment #27 by DakotaP214
Sunday, January 16, 2011 @ 05:48:04 PM

the way i unlocked mine is i did all those quests then the island getaway quest, went back to castle and slept and instantly popped

Comment #28 by MAIRINE GENERAL
Sunday, January 30, 2011 @ 06:12:53 PM

i beet every quest and didnt get a few achievments (last time i will buy another fable game)

Comment #29 by jorgeeee
Saturday, February 05, 2011 @ 12:41:09 PM

are these quests disabled after you've become king/queen?

Comment #30 by benjjdrummer85
Tuesday, February 22, 2011 @ 12:16:38 AM

i had some problems with this one

Comment #31 by Ellet 2
Friday, February 25, 2011 @ 04:45:15 PM

I have done all the quests except the ones where you have to collect the flowers, books, and gnomes. I'm king now so why havent any of these missions popped up? Was i suppose to do this before becoming king?

Comment #32 by SouP x360a
Sunday, February 27, 2011 @ 02:19:20 AM

seeing that people say sleeping gets it to pop, i ran to my house in brightwall, except i ran into my wife..i brought to the bed for a little unprotected sex, and it popped right after that. it seems sleeping or sex, anything to do with a bed will get it to pop

Comment #33 by xHollykesh
Saturday, March 05, 2011 @ 06:45:42 PM

I can't even fight the first quest "Get wood for Driftwood". Anyone knows how or where I can get it?

Comment #34 by Barrosy
Sunday, March 06, 2011 @ 10:57:58 AM

Lol, I've done pest control, gift wood for driftwood and now I don't get a new quest of it... What now?

Comment #35 by Barrosy
Sunday, March 06, 2011 @ 12:33:49 PM

Found it, you need to escort a gambler, to find this quest, it is a quest wich starting ay Bowerstone Market. NOT DRIFTWOODS.

Comment #36 by TatteredMorph
Tuesday, March 08, 2011 @ 06:55:40 AM

it seems that doing these quests seems to trigger the achievement:
Do:
Restoration (Give 750 gold to a guy in Millfields)
Leave Millfields and go to sleep or do a couple of other quests (so that the bridge can be restored)

This then makes available:
Pest Control (Kill the hobbes in Driftwood)
and then:
Gift wood for Driftwood (Take a letter to a carpenter in Silverpines)

Once these are done you then need to do:
An Island Getaway (Escort the gambler from the pub in Bowerstone Market to Driftwood)

The achievement then popped about ten minutes later for me for no apparent reason (I was just running through Millfields) It's possible that sleeping could well trigger it as well, but I can't confirm this.

Hope this helps. :-)

Comment #37 by Flamin B
Sunday, March 13, 2011 @ 03:47:24 PM

Yeah, it pops up a while after you do the quests.

In fact, it surprised me a bit, because it came up while I was in the middle of the "Reaver's Unmentionables" quest. LOL!

Comment #38 by Snarker
Monday, March 21, 2011 @ 06:46:02 AM

Me and a coop buddy got this randomly online, he had finished the quest the day before and for some reason it popped the minute we entered coop :P

Comment #39 by fooyfoofy
Friday, April 01, 2011 @ 11:56:54 PM

just do all the quest avialable thenit usually glicthes out and it gives you the achievment when you get a different achievment, play the mourningwood fort game, or have a baby.

Comment #40 by Big Dave Blue
Sunday, May 01, 2011 @ 08:43:44 AM

The achievements pops 24 in game hours after the final task

Comment #41 by petes meat
Monday, May 16, 2011 @ 03:12:19 PM

I can't find the quest for Pest Control. I am already King and finished the final battle. Was this something I needed to do before the final battle?

Comment #42 by gipito1
Saturday, May 21, 2011 @ 05:40:51 AM

You have to wait a couple of hours (do some quests, rob thingĀ“s from peoples houses...

Comment #43 by cC x PowerHouse
Sunday, June 19, 2011 @ 08:35:10 PM

You have to wait for the island to be rebuilt.

Comment #44 by Your skill died
Saturday, July 09, 2011 @ 08:21:17 PM

Confirmed. You must do the quest restoration by giving the man 7,000 gold to restore the island. Then you must complete the quest 'The debt' otherwise the 2nd quest wont appear in your quest list. Afterwards you have to wait an allocated amount of time for the third quest to pop. I find sleeping then quitting and entering works fine. After you convince the lumberjack to move to driftwood. You must continue to bower-stone market and lead another one by hand-held walking to driftwood (BULLSHIT). After the trilogy of quests are completed proceed to the nearest bed to sleep in the bed for 24 hours. This would work i've found 75% of the time. If not, do another quest, have a kid, do something outstanding in the game that makes a difference and the achievement defiently does pop.

-Hope this h

Comment #45 by Nightfiree3
Saturday, August 20, 2011 @ 11:01:46 PM

I gave the guy the money, i've killed hobbes, I did the mission with the
lumberjack, I escorted the guy there (By hand -_-) and after went off to another area and slept till morning. After that I went back to driftwood and still no
achievement. T_T This is bull.

Comment #46 by XxSickRapper2xX
Saturday, September 03, 2011 @ 10:29:41 AM

After i took rusty to driftwood i jus went back to my castle held hands wit my wife had unprotected sex than after that was done i got the chevo

Comment #47 by Stough89
Friday, September 30, 2011 @ 01:45:33 PM

The reason it takes so long to pop is like everything in the game the development of a location is not instant similar to the dark sanctum.

Comment #48 by Adeodattus
Tuesday, November 22, 2011 @ 12:12:07 PM

Anybody know if there's a glitch in the marriage for inconvenience quest? When I approach the guy in brightwall, he does not talk/interact with me. This topic is not relevant but I'll appreciate any guide from you guys.

Comment #49 by indianidiot
Thursday, December 22, 2011 @ 02:33:50 AM

just got it thx

Comment #50 by bluetop20
Thursday, February 16, 2012 @ 09:11:25 AM

Go to Millfields and run to the top of the hill that has the Stonehenge-like ruins on it. Talk to the man by the broken bridge and then press the "Accept" button to pay him 750 gold to complete the "Restoration" quest. Leave the area and allow 24 hours to pass in the game.


Return to the location of the "Restoration" quest and cross the newly built bridge. Follow the path into Driftwood.


Talk to the man in the gypsy camp with the quest marker above his head. Press the "Accept" button and then follow the objective trail. Kill all four groups of Hobbes you encounter, then return to the man.


Wait for another 24 hours to pass in the game, then go to Bowerstone Market. Go to the second floor of the pub and talk to the gambler. Accept the "Island Getaway" quest from him, then hold

Comment #51 by bluetop20
Thursday, February 16, 2012 @ 10:07:25 AM



then hold his hand and lead him in the direction of the objective trail.


Exit Bowerstone Market toward Millfields and then fight off all attackers along the path. Continue to follow the objective trail and lead the gambler to Driftwood. Follow the objective trail through Driftwood until the gambler rewards you with Guild Seals.


Allow another 24 hours to pass in the game and return to Driftwood. Go to the main island and accept the "Giftwood for Driftwood" quest from the gypsy with the quest marker above his head.
# 7

Travel to Silverpines and follow the objective trail. Fight the balverines along the way until you reach the indicated cabin. Go inside and hold down the "Accept" button in front of the carpenter to complete the quest. Wait another 24 hours in the game to rec

Comment #52 by bluetop20
Thursday, February 16, 2012 @ 10:09:22 AM

remember just find a bed and sleep this will make the 24 hrs pass by right away.

Comment #53 by Killerchronic
Wednesday, February 22, 2012 @ 11:52:05 AM

Can any single one of you read?
It says, and i quote:

[b]You must now leave Driftwood for the effects to take place and about 15 minutes later the achievement will pop.[b]

Basically its not going to pop straight away the time delays is because the place is being built.

Or maybe read the cheevo guide and not just comments, sheep.

Comment #54 by Nava uk
Monday, April 30, 2012 @ 09:03:44 AM

I've got the achievement but the carpenter from silverpines hasn't left his cabin. I gave him the letter and he said he was going to go there. I then took the gambler to driftwood I've managed to hit the flit switch a few times but now it's on a stand I can't quite reach next to a tree. I don't know why but the place has been built up but not fully but the carpenter is still in his house. Any1 else got this problem or know how to sort it out cause I want the gold key. HELP!

Comment #55 by ciaqman
Monday, July 30, 2012 @ 07:27:21 PM

how do i get this quest to appear? do u have to be at a certain point in the game to do it?

Comment #56 by HerBravado
Wednesday, September 19, 2012 @ 06:43:58 PM

After you complete the last step (which involves going to the pub like mentioned above) go sleep in a bed--which will pass the time equal to a whole day. When you wake up, the achievement pops.


You need to register before being able to post comments.
 


 
 
Game Info
Developer:
Lionhead Studios
Genre:

Release:

US October 26, 2010
Europe October 29, 2010

HDD Space Required : 5.7 GB
Backward compatible on Xbox One: Yes
Price: $19.99USD
Collection:7002
Wishlist:678
 
 
Screenshots
 
 
Videos
 
 
MyAchievements
You need to log in or register to use MyAchievements.
 
 
Rating
   

88   


83


0

You need to log in or register to rate games.

User Score is based on 2379 user ratings.